SmartSensor

51 thoughts on “SmartSensor”

      1. ok found that smart sensor will not wit xp os so I do have computer with window7 and b newest version of rsc64 installed. down loaded SmartSensorUtility and tryed to load drivers and use my smart sensor with no luck get a fw upgrade failed check board/port rsc64 does not see board either. help sos

        1. Hi Daniel

          Im so sorry, but I did not get a notification about you question here on the site. Do you have the SmartSensor working now, or do you still need help. If you need help, plesa contact me by mail to be sure that I get your message

          Kindly Kåre

  1. Hi Kare
    Ade on the SlotForum is producing a light pcb working off an Arduino .
    I already have your super smart sensors and boxed Arduino Uno with the RJ45 outlet. I use them successfully with PCLC ,but my start lights are old and work off a parallel port . What Ade proposes sounds really good. He asked me to find out from you if reprogramming the Arduino with the appropriate PCLC sketch would be OK. I really don’t understand such things – plug and play is my preferred option!!
    If you look at his latest thread you will see my replies (TIMCSLOT) to help make things clear.
    I think and hope that I already have the necessary hardware to make his lights work but I am not sure.
    Any help much appreciated.
    Tim

    1. Hi Tim
      Thank you for the post on my new site :-)

      I am currently planning to include the SSDC and PCLC startlight in the SmartSensor program, so you can use SmartSessor for Startlights on PCLC and SSDC. Im not sure when I can complete this work, as im in need of time :-)

      This will be the only way to keep the SmartSensor functionality and startlight functionality in one box.

      Electrical connections must still be made acording to the drawings on Startlight section of this website.

      Kindly
      Kåre

  2. Thanks Kare. I’ll just wait until you produce something- no pressure!
    Will you post news on SlotForum or just through your site?

    Tim

    1. Hi Tim

      Did you see the update, that you can use the new firmware in the Utility tool and have the SmartSensor working with Startlight from PCLC and SSDC now?

      Kåre

  3. Hi Kåre
    Having just used the Smartsensor together with SSDC for 3 evenings, we have a constant issue. Car no. 3 “Orange” on the Scelextric Power base 7042 seems to start the race in the pit, no matter what we do. It is not every race but so many that the drivers complained about it. We are using your smartsensor together with SSDC, and it work for all the other cars, we have been running 6 cars, but mostly 4 cars.
    We are also experiencing constant light on some of the lights on the Smartsensor box, throughout the race; it does not help to drive through the pit lane.
    Any help?

    Henrik

    1. Hi Henrik

      This is a known issue. The problem is that SSDC is sending out startlight info, that causes the SmartSensor to pit in car #3. For this reason I have made 3 firmware packages, one for each major RMS software. So to fix your problem, just download the utility software from this site, and install the SSDC Firmware. Detailed info in the manual for the utilty software, also found on this site. I hope this solves your problem, else please contact me again.
      Kindly
      Kåre

      1. Hi Kåre
        I can’t find them, can you post a link please.

        One more question, i am using both SSDC and RCS64 will I have to reflash when going between systems?

        TIA

        1. Hi Henrik

          Yes, you need to do so in the current version. But very soon when the SmartSystem is released, this will no longer be a issue, then you just need to choose the RMS in a Dropdovn on the computer.

  4. hi Kare I have RCS64 and have pit pro already if I added smart sensor could I use it to pick up sector timing / identify where pace cars are on the track? If so in theory if you have a big track buy two sensor kits therefore having two pace car identifiers per lane. finally did hte the mega smart sensor get anywhere?

    Not sure where to comment or ask question so apologies if in the wrong the place, all the best everyone.

    1. Hi Thinbloke

      Thank your for the questions :-)

      RCS64 do not support sector times, but when they do, the smartsenor is designed to also be used for thir purpose. From the SmartSensors point, there is no problems in having several around the track on big tracks. Regarding the SmartMegaSensor, it has not evolved. I m working on a new wireless solution that will replase the mega sensor.

      To post question directly about RCS64, you can user their forum. look in http://rcs64.notlhosting.com/forum/

      And if you would like to change your pit pro, you can always by a SmartSensor :-)

      Kindly

      Kåre

  5. Hi Kare
    I’ve just purchased a light board from Ade on SF . If I connect this board through the RJ45 socket on my Smartsensor that I use with PCLC ,will I get full functionality? Ade is concerned that I may only get stop go and track call but no red light countdown and has asked me to check with you.

    1. Hi Tim

      PCLAPCOUNTER have not imlementeted the full SmartSensor protocol, so I only have info available that PCLC is giving through the PitPro interface. This is only Start, Stop and track call. I can’t do it anyway else, and not even the new SmartSystem will improve on this as I still don’t have access to the required information through the PCLC interface.
      I’m sorry this was not the answer you where looking for, but it’s the best I have 😯. There’s more info about LightTower implementation in SmartSensor section of this Website.

      Have a great weekend

      Kåre

    1. Hi Tim

      A few weeks ago I had a session with Guy, where I told him the basics of setting of communicating with the SmartSensor. I have not heard from him since. At the time he did not see it as a problem to build in the full smartSensor communication, and also to communicate with the new SmartSystem. …But still no news of progress.

  6. Hi Kare
    That is great news.
    Just now I downloaded Guy’s latest version of PCLC.
    Do I need to do anything else to get Ade’s start lights to work along with the Smartsensors apart from plugging them in to the RJ 45 socket?
    Regards
    Tim

  7. Hi Kare
    having a few problems getting my lights to function.
    Guy thinks I need to update the firmware on my Smartsensor .
    If this is the case do I just go to the utility and launch version 1.0.019 and run. If so do I upload firmware for RCS64 or PCLC – Guy thinks RCS64.
    I’m determined to get it right but I’m no computer expert.!!
    Do I have to do anything with the Arduino software? -I hope not.
    All works well with pit sensing on Pitpro mode as before -the issue is getting PCLC to work the lights when I set up on SSmode on the latest PCLC version

  8. Hi, Sensor arrived this morning, amazing given it was only ordered at the weekend, outstanding :)

    Starting to get it to talk to my mac, so far most commands seem to work for the sensors, have yet to have the parts for the light gantry arrive so haven’t tried those commands.

    Finding a problem setting the mode, reading the mode by sending 0b00000101 works, and responds with a zero – the manual suggests this should be a 1 for PP mode and a 2 for SS mode, not sure what 0 represents – device appears to actually be in PP mode though from how it behaves.

    Attempting to set the mode to SS, by writing 0b00000100 and 0b00000010 (or the second byte as 0b00000001 for PP mode, or indeed 0b00000000) results in the port locking up needing the software to reset – the device seems fine though and can be reset just by restarting the software on the laptop.

    Wondering if I’m reading commands 4 & 5 right in the manual?

    Many thanks.

  9. Hi Kaare

    I am trying to use your smart sensor on an windows 10 32 bit version.

    Every time that I try to install the arduino driver, I only get the 64 bit version, and then my windows 10 laptop will not boot.

    Do you know where to get an 32 bit driver version?

  10. Hi!

    So I just updated to latest version of RCS64 and now the pit in and out sensors are reversed.

    Please remind me how I changed pit in sensor with pit out.

    Thanks
    Carl

    1. In the RCS64 system theres a menu for testing the SmartSensor, in the same menu you can chenge the direction of the SmartSensor, In the manual on this site I belive you can find the info, or reference the RCS64 Manual.

  11. Hi Kare

    I am running RCs64 and I already have pit lane pro so I was looking for 3 sectors to improve the ability / consistency of pace cars for my tracks. Would this work with the new smart sensor system and what would I need to purchase? Thanks

    1. Hi Andy
      Sorry for not replying ealier, but I was not notified about you comment.
      The Sector timing is as far as I know not part of any development from the RCS sowftware providers. The SmartSensor can give the info, but it cant be used anywhere.

  12. This is probably a LapCounter issue BUT when using smart sensors before and after pitlane and run the program in SS mode the refueling process starts directly when passing over the first smart sensor. The way we would want it to work is that the smart sensors only tell the program that it is possible to refuel but you have to stop the car in the pitlane and manually start refueling process with for example holding breakbutton.

  13. Cannot update FW (Utility or Arduino) although I have followed instructions on the manual. Of interest, then device manager suggest I should use COM 5 (CH340), yet I receive a failure dialog box stating failed and to look into the port/board.
    I know sensors are properly installed so assume board is working properly.
    I have downloaded Arduino Uno using the install device drivers button in RCS64.
    Although connected to the board I’m not connected to the APB or the sensors as my router not strong enough to get wi-fi signal to where the track is located. Could that be the reason I cannot make the Smartsensor work / update?

    1. Hi

      Can you provide me some screenshots of the Device manager. You schould be able to upload the new firmware directly from within the RCS64 interface. But you need to make sure that the port is configured with the right drivers before RCS64 can update it. Please send an email to kaare@seras.dk with windows version, and a screenshot of the devicemanager.

      Kindly

      Kåre

  14. Got it fixed. Watched a You Tube video by Ade and was able to figure out how to update the Firmware using RCS64.
    Thanks
    By the way, do you know of a commercially available Start Lights that work with RCS64?

  15. How do you know SmartSensor is working? I have updated the Firmware yet when I enter the pit lane there is no exit option on the screen (RCS64). I does tell me I have entered the pit lane.
    Also, now that I have a COMPORT (COM5) and have been successful at updating the Firmware testing the sensors does not produce the same results as when I fist install them…is that normal once you have identified the COMPORT and updated the firmware?
    Finally, when using the Simple Arduino Test button I’m not sure what to look for in terms of knowing if SmartSensor is working
    Thanks

  16. Hello,

    I am the developer of ESRM software.
    A presentation on SlotForum: http://www.slotforum.com/forums/index.php?showtopic=142601

    My FaceBook page: https://www.facebook.com/ESRM-Easy-Slot-Race-Management-214546085642504/

    Some users ask me to allow the use of smartsensors.
    I find this very interesting but I do not have this material. The software being 100% free, I can not afford to buy all types of hardware to interface.
    Could we possibly talk about it by email?

    thank you in advance

    David

  17. Hej Kåre.
    Jeg har haft en smartsensor liggende i over et år siden fruen gav mig en i julegave, Nu har jeg så endelig fået en stationær bane op og stå, og installeret sensoren. Sagen se den at jeg bruger rcs64 og gerne vil have 2 pitlanes. Dette burde kunne lade sig gøre hvis sensoren bliver sat i pitpro mode. Men det volder en del ballade. Når sensoren er i pitpro mode pitter der tilfældige id’er ind og til tide går det helt amok, således at løbet afsluttes ved pitentry eller løbet startes, og første gang der gives gas afsluttes løbet. Det skal lige noteres, at sætter jeg sensoren i ss mode med pit ind og ud så køre det upåklageligt. Jeg har opdateret firmwaren via rcs64. Kan det skyldes en driver???
    Hilsen
    Stefan

    1. Hej Stefan
      Det er ikke umiddelbart muligt at have to pitlanes. RCS64 understøtter ikke 2 SmartSensorer. Jeg har noget software på tegnebrættt der vil kunne løse det for dig, men det er ikke klart, og jeg har ikke tiden til at få det helt færdigt foreløbigt. Din sensor burde virke fint i PP-mode, har du den nyeste version af RCS64?

      1. Tjek. Det har jeg. Som sagt virker den fint som smart sensor, men som pitpro, pitter den vilkårlige id ind, oven i købet id som ikke er aktive i løbet. Og til tider afsluttes løbet ved pit ind eller ved afgivelse af speeder. Når vi har haft kørt er det med en sensor i hver pitlane som så pitter ind og vi kommer ud af pit ved at give gas igen. Det er dog mest id 6 som bliver pitter vilkårligt ind, men til tider også andre.

        1. Hej Stefan¨
          Så er jeg med på hvordan du har sat det op. Det eneste som jeg kan tænke umiddelbart er at du får noget “falsk” lys ind, som provokerer sensoren. i SS mode vil det ikke være et problem for Pit-Ud sensoren, da den kun sender noget ud hvis en bil er i pit, men i PP mode sender den ud hver gang den ser noget. Du kan prøve at skygge for sensoren med et midlertidigt tag over pitten, eller slukke lyset for at se om det er problemmet, du kan også sætte følsomheden på sensoren fra 2-3, det burde også hjælpe. Jeg er ude og rejse de næste par uger, så der vil jeg ikke kunne hjælpe.
          Held og lykke med det.

          Kåre

  18. Jeg leger lidt videre med det. Så må vi se om det ændre noget. Kan bare ikke lige her se hvordan det hænger sangen med at løbet til tider bliver afsluttet i utide.

    En tanke har dog ligget og ulmet lidt….. Når nu jeg ikke har haft problemer i SS mode. Kunne det så tænkes det var en ide at købe 2 sensore mere, og parallel forbinde dem med de to som fulgte med, og derved have 4 sensore SS mode som kunne sidde i hver sin pit.

Leave a Reply

Your email address will not be published. Required fields are marked *


*

Racing electronics for SSDC